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THEORETICAL CONCEPTS OF OPERATING SYSTEM 
 

Introduction to Software: 
 A software is set of instructions that perform specific task. It interacts basically with 

the hardware to generate the desired output.  

Types of Software 

 Software is classified into two types:  

1) Application Software  

2) System Software  

Application Software:  

 Application software is a set of programs to perform specific task. For example MS-

word is an application software to create text document and VLC player is familiar 

application software to play audio, video files and many more.  

System Software:  

 System software is a type of computer program that is designed to run the 

computer’s hardware and application programs. Example Operating System and 

compiler. 

Introduction to Operating System (OS):  
 An Operating System (OS) is a system software which serves as an interface 

between a user and a computer. 

 Some of the popular Operating Systems used in personal computers and laptops are 

Windows, UNIX and Linux. The mobile devices mostly use Android and ioS as 

mobile OS. 

Uses of Operating Systems: 
 The main use of Operating System is  to ensure that a computer can be used to 

extract what the user wants it do. 

 Easy interaction between the users and computers. 

 Starting computer operation automatically when power is turned on (Booting). 

 Controlling Input and Output Devices. 

 Manage the utilisation of main memory. 

 Providing security to user programs. 

Types of Operating System: 
 Operating System are classified into the following types depending on their 

processing capabilities. 

Single User Operating Systems  
 An operating system allows only a single user to perform a task at a time. It is called 

as a Single user and single Task operating system.MS-DOS is an example for a 

single user and single task Operating System. 

Multi-user Operating Systems: 
 It is used in computers and laptops that allow same data and applications to be 

accessed by multiple users at the same time. The users can also communicate with 

each other. Windows, Linux and UNIX are examples for multi-user Operating 

System. 
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Key features of the Operating System: 

Graphical User Interface (GUI): 
 The GUI is a window based system with a pointing device to direct I/O, choose from 

menus, make selections and a keyboard to enter text. Its vibrant colours attract the 

user very easily. 

Memory Management: 
 Memory Management is the process of controlling and coordinating computer’s 

main memory and assigning memory block (space) to various running programs to 

optimize overall computer performance. 

Process management: 
 Process management is function that includes creating and deleting 

processes(program) and providing mechanisms for processes to communicate and 

synchronize with each other. 

 The following algorithms are mainly used to allocate the job (process) to the 

processor. 1. FIFO   2. SJF   3. Round Robin 4. Based on Priority 

Security Management: 
 The major challenge in computer and software industry is to protect user’s legitimate 

data from hackers. The Operating System provides three levels of securities to the 

user end. They are 

(1) File access level   (2) System level (3) Network level 

Fault Tolerance:  
 The Operating Systems should be robust. When there is a fault, the Operating 

System should not crash, instead the Operating System have fault tolerance 

capabilities and retain the existing state of system. 

File Management:  
 File management is an important function of OS which handles the data storage 

techniques. The operating System manages the files, folders and directory systems 

on a computer. 

Multi-Processing: 
 This is a one of the features of Operating System. It has two or more processors for a 

single running process (job). Processing takes place in parallel is known as parallel 

processing. Since the execution takes place in parallel, this feature is used for high 

speed execution which increases the power of computing. 

Time-sharing:  
 This is a one of the features of Operating Systems. It allows execution of multiple 

tasks or processes concurrently. For each task a fixed time is allocated. This division 

of time is called Time- sharing. The processor switches rapidly between various 

processes after a time is elapsed or the process is completed. 

Distributed Operating Systems: 
 The Distributed Operating System is used to access shared data and files that reside 

in any machine around the world using internet/intranet. The users can access as if it 

is available on their own computer. 

 The advantages of distributed Operating System are as follows: 

 A user at one location can make use of all the resources available at another 

location over the network. 

 Many computer resources can be added easily in the network. 

 Improves the interaction with the customers and clients. 



 

4 

 

Working with Windows Operating System: 
 Every computer needs an Operating System to function. Microsoft Windows is one 

of the most popular Graphical User Interface (GUI). Multiple applications can 

execute simultaneously in Windows, and this is known as “Multitasking”. 

Some of the functions of Windows Operating System are: 
 Access applications on the computer (word processing, games, spread sheets, 

calculators and so on). 

 Load any new program on the computer. 

 Manage hardware such as printers, scanners, mouse, digital cameras etc., 

 File management activities (For example creating, modifying, saving, deleting files 

and folders). 

Windows Desktop:  
 The opening screen of Windows is called “Desktop”. 

 Windows allows you to change the appearance of the desktop.  

 The desktop shows the Start button, Taskbar, Notification Area and date and time. 

The Icons: 
Icon is a graphic symbol representing the window elements like  files, folders, shortcuts 

etc., Icons play a vital role in GUI based applications.  

 Standard Icons: The icons which are available on desktop by default while 

installing Windows OS are called standard icons. The standard icons available in all 

Windows OS are My Computer, Documents and Recycle Bin.  

 Shortcut Icons: Shortcut icons can be created for any application or file or 

folder. By double clicking the icon, the related application or file or folder will open. 

The Window:  
Window is a typical rectangular area in an application or a document. It is an area on the 

screen that displays information for a specific program.  

 Application Window: It is an area on a computer screen with defined 

boundaries, and within which information is displayed. Such windows can be 

resized, maximised, minimised, placed side by side, overlap, and so on.  

 Document Window: A document window is a section of the screen used to 

display the contents of a document.  

Elements of a window:  

 Title Bar: The title bar will display the name of the application and the name of 

the document opened. It will also contain minimize, maximize and close button. 

 Menu Bar: Menus in the menu bar  is seen under the title bar.  

 The Workspace : The workspace is the area in the document window to enter or 

type the text of your document.  

 Scroll bars: The scroll bars are used to scroll the workspace horizontally or 

vertically.  

 Corners and borders: The corners and borders of the window helps to drag 

and resize the windows. 

Files and Folders: 
 File is a collection of related data or information that is created by Application. 

 Folder is a way to organize files into group and put them under a common name. 
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Create a new folder: 

Method I:  
 Open Computer Icon. 

 Open any drive where you want to create a new folder. (For example select D:) 

 Click on File → New → Folder. 

 A new folder is created with the default name “New folder”.  

 Type the name you want and press Enter Key. 

Method II:  

 In the Desktop, right click → New → Folder.  

 A Folder appears with the default name “New folder”. 

 Type the name you want and press Enter Key 

Finding Files and Folders: 
You can use the search box on the Start menu to quickly search a particular folder or file 

in the computer or in a specific drive.  

To find a file or folder: 

 Click the Start button, the search box appears at the bottom of the start menu. 

 Type the name of the file or the folder you want to search. Even if you give the 

part of the file or folder name, it will display the list of files or folders starting 

with the specified name.  

 The files or the folders with the specified names will appear, if you click that file, 

it will directly open that file or the folder.  

Searching Files or folders using Computer icon 

 Click Computer Icon from desktop or from Start menu.  

 The Computer disk drive screen will appear and at the top right corner of that 

screen, there is a search box option. 

 Type the name of the file or the folder you want to search. Even if you give the 

part of the file or folder name, it will display the list of files or folders starting 

with the specified name. 

 Just click and open that file or the folder. 

Rename a File: 

 Select the File or Folder you wish to Rename. 

 Click File→ Rename. (or)  

 Click the right mouse button over the file or folder and Select Rename from 

the pop-up menu (or)  

 Press F2 . 

 Type in the new name. To finalize the renaming operation, press Enter. 

Moving/Copying Files and Folders: 

Copy: It means to make a duplicate copy of a file. The original file remains at the source 

location. 

It uses the Copy & Paste option. 

Click Edit → Copy or Ctrl + C or right click→ Copy from the pop-up menu. 

Click Edit → Paste or Ctrl + V or Right click → Paste from the popup menu. 
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Move: It means to transfer a file from one location to another. The original file is moved 

to the destination location. 

It uses the Cut & Paste option. 

Click Edit → Cut or Ctrl + X or right click → Cut from the pop-up menu. 

Click Edit → Paste or Ctrl + V or Right click → Paste from the popup menu. 

Recycle bin: 

 Recycle bin is a special folder to keep the files or folders deleted by the user, 

which means you still have an opportunity to recover them.  

 The user cannot access the files or folders available in the Recycle bin without 

restoring it.  

 To restore file or folder from the Recycle Bin. 

Create shortcut in Windows OS: 

Shortcuts to your most often used folders and files may be created and placed on the 

Desktop to help automate your work.  

 Select the file or folder that you wish to have as a shortcut on the Desktop. 

 Right click on the file or folder. 

 Select Send to from the shortcut menu, then select Desktop (create shortcut) 

from the sub-menu. 

 A shortcut for the file or folder will now appear on your desktop and you can 

open it from the desktop in the same way as any other icon. 

Shutting down or Logging off a Computer: 

 To Log off/Shut down the computer: Click start → log off (click the 

arrow next to Shut down) or Start → Shutdown. If you have any open programs, 

then you will be asked to close them or windows will Force shut down, you will lose 

any un-saved information if you do this.  

 Switch User: Switch to another user account on the computer without closing 

your open programs and Windows processes. 

 Log Off: Switch to another user account on the computer after closing all your 

open programs and Windows processes. 

 Lock: Lock the computer while you're away from it. 

 Restart: Reboot the computer. (This option is often required as part of installing 

new software or Windows update.) 

 Sleep: Puts the computer into a low-power mode that retains all running programs 

and open Windows in computer memory for a super-quick restart. 

 Hibernate (found only on laptop computers): Puts the computer into a low-power 

mode after saving all running programs and open Windows on the machine's hard 

drive for a quick restart. 
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